Installed WebSphere (WAS) Community Edition 1.0 in VMware

I spent the better part of the late evening/early morning yesterday (today?) getting acquainted with WebSphere Application Server Community Edition v1.0.

I had tried to play with Gluecode in the past, as we were going through the acquisition, and the installation was far from easy. This time, things are much smoother, even for a relative newbie to Linux like me.

As always with IBM middleware, MAKE SURE you’re running one of the supported linux distributions. For me, that was RHEL 4.0 Update 1, for which I already had a clean VMware image to start with. I then downloaded all the files from the ibm.com website (free registration required) from within linux, extracted all the files in sub-directories and proceeded to start the installation:

  • Install IBM’s 1.4.2 JDK
  • Edit all .bash_profile files to include the JAVA_HOME and PATH properly (IBM stuff typically gets installed to /opt)… I ran into an issue where a symlink to /usr/bin/java was preceeding IBM’s JDK in the path and nothing would work (due to the gcj JRE being installed)…
  • Install WAS CE (it launches a nice GUI installer)
  • Logout/Login (to refresh your java settings)
  • Try out WAS CE, by launching /opt/IBM/WebSphere/AppServerCommunityEdition/bin/startServer.sh as root
  • Create cute launcher icons on KDE’s desktop…

WAS CE launches in a terminal window, and takes about 30 seconds to load all its modules, It will then tell you that everything is OK.

Initializing Universal Application Launcher........
Launching Start the server........
Booting Geronimo Kernel (in Java 1.4.2)...
Starting Geronimo Application Server
[************] 100%  67s Startup complete

Listening on Ports:
      1099 0.0.0.0 RMI Naming
      1527 0.0.0.0 Derby Connector
      4201 0.0.0.0 ActiveIO Connector EJB
      4242 0.0.0.0 Remote Login Listener
      8080 0.0.0.0 Tomcat Connector HTTP
      8443 0.0.0.0 Tomcat Connector HTTPS
     61616 0.0.0.0 ActiveMQ Message Broker Connector

Started Application Modules:
      EAR: org/apache/geronimo/Console/Tomcat
      WAR: org/apache/geronimo/applications/Welcome/Tomcat

Web Applications:
      http://localhost.localdomain:8080/
      http://localhost.localdomain:8080/console
      http://localhost.localdomain:8080/console-standard

Geronimo Application Server started

At this point, it’s pretty obvious where we want to go… the console! What’s also nice with VMware is that I can actually hit the server from my host system, by typing http://192.168.1.103:8080/console which was assigned to Linux by my Linksys router. Here is what the console looks like:

And here is the info displayed when you first log in, using the provided userID and password (system/manager):

Next up is for me to zip up this VMware image, and distribute to the internal IBM technical community, so they can get a fast start at developing applications on this, and basically improving their skills on our new offering.

À propos de Jean-Francois

Je travaille dans le domaine du web, je suis photographe à mes heures, et bientôt skipper de mon nouveau voilier!

Laissez un commentaire